PAGE  
1

BRIDGEWATER RARITAN HIGH SCHOOL

BUSINESS EDUCATION

Photo Editing and Web Design

1966 TV Batman Website
NAME: ______________________________     PERIOD: _____

Immediately put your name on this assignment package and make sure you do not lose it. 
You will not be able to complete the Batman Website without this package. If you lose your package 
and need a new one you will have two grade points deducted from your 2nd Marking Period grade.

Website Name:
1966 TV Batman Tribute Site
URL:
1966TVBATMAN.COM (confirmed available on Whois*) 

Audience:
Batman Fans

Goal:
To provide info about the 1966 Batman TV Show.
To learn how to create websites in MS-Frontpage.

*WHOIS is a public database that can be searched free of charge to determine the owner of a domain name that is used on the World Wide Web. If the result “no match for domain” is returned then most likely that domain name is available for your use for a yearly fee. You can access the Whois database to check the availability of domain names at: www.internic.net/whois.html

The first step of setting up the website in the correct location is very important and many students get this part wrong. You must Browse to your student space on the student server and  then create a New Folder and save the website in the new folder.

Open Frontpage and create a blank 1 page website (File>New>New Web Site>
One Page Web Site>Browse [to your web design folder]>Create New Folder icon> 
name the new folder tv_batman_website>OK>Open>OK)
Notice that a web page called index.htm is created. Index.htm is the default page that browsers look for when you type in a URL.

It is extremely important that all images be stored in the Images Folder within the Website Folder and that the images are Inserted from that folder. If you were to Insert an image from another location and later move it to the Images Folder, that will not work.

Copy Public>Mazza>Batman Practice Site>Images into your tv_batman_website folder, 
replacing the existing images folder.
File Properties is where you can change settings that apply to the entire web page such as background color, background image, text color and hyperlink colors. Margins can also be set so your web graphics and text are not right up against the edges of the webpage.


If it is not already open, double click on index.htm to open the page. Go to File>Properties. 
Under the General Tab, enter 1966 TV Batman Home Page in the Title field. Next click on the Formatting Tab and set the Background of the page to a Dark Blue (Background>MoreColors> Custom>Red=0, Green=0, Blue=85), Set Text to White, Hyperlink to Yellow, Visited Hyperlink to Silver, Active Hyperlink to Red. Click on the Advanced Tab and set the Top, Bottom, Right and 
Left Margins to 12 Pixels. Select OK to exit the Page Properties Dialog Box and Save (File>Save).

JPEG and GIF are the primary file formats used for graphics in web pages. JPEG files are best for photographic images and GIF files are often used for logos, icons and banners. A GIF file can have its background set to transparent so that the graphic will work better with the web pages background color/design.

At the top of index.htm, Insert batman_logo.gif from your images folder (Insert>Picture>
From File). Center the picture by selecting it and clicking on the Center icon on the toolbar just 
like in MS-Word. Select the image and bring up the Pictures Toolbar (View>Toolbars>Pictures). 
Click on the Set Transparency Color icon (it looks like a yellow and white piece of chalk) on the Picture Toolbar and your pointer will turn into an icon that looks like the top of a pencil. 
Click on the gray background area of the image and the background will disappear.

Notice that all the file names are lower case characters and have no spaces or special characters. 
This is an important convention to follow so that there will be no server problems with your website.
When creating websites, there is a limited selection of fonts and styling that is used. This is because you cannot 
be certain what fonts will be installed on the viewer’s computer. So fonts are kept to a minimum (Arial, Times, Courier) to ensure compatibility. Go to yahoo.com, amazon.com, or hbo.com and notice that  fonts are formatted for the most part in Arial. If a font is stylized (like in a logo) then it is usually saved as a graphic. In FrontPage and other web page layout software, pre-defined styles are mostly used such as  Normal, Heading 1, Bulleted List.

Under batman_logo.gif type the following: All You Need to Know About the 1966 Batman Television Show and format it as follows: Heading 2, color Yellow.

Horizontal Lines help you define sections and separate information on a web page. They also can add style to 
a web page. You can modify the look of a Horizontal Line by right clicking it and selecting Horizontal Line Properties.

Put your cursor in front of All You Need to Know About the 1966 Batman Television Show and go to Insert>Horizontal Line. Next right click the Horizontal Line and select Horizontal Line Properties make the following settings, Width: 75%, Height: 4 pixels, Color: Red. Put your cursor at the end of the type and insert another Horizontal Line. The line will have the same attributes as the previous line that was created. You should now have a red line above and below the yellow type.

A Marquee is a way of drawing the viewer’s attention to specific information on a website. 

Select All You Need to Know About the 1966 Batman Television Show and go to 
Insert>Web Component>Marquee>Finish. In the dialog box, click off Continuous and click OK. Save your web page (File>Save).
Sometimes when you define a Marquee in FrontPage text  format of the type  is lost. If that happens, select 
the type and reformat it.
To make sure that what you are creating will look good when viewed on the web, it is recommended to 
preview your work in a real browser such as Internet Explorer.


Go to File>Preview in Browser and select the top choice. If you are prompted to save the file then do so. Your web page will open in the browser and you can see how it will look and how the marquee will work.
You can also preview your design within FrontPage by clicking on the Preview Button at the bottom middle of the website window. There is also a button to view the underlying HTML code (Code) and a button to see both the Design and HTML Code at the same time (Split).

In FrontPage you work with text just like in MS-Word.

Below the Marquee and Horizontal Lines click to add a text cursor and type the following: 
Batman and Robin and format it as follows: Heading 3; Centered; type color= Aqua.


Below the Batman and Robin text, insert and center the picture batman_robin.jpg.


Below batman_robin.jpg type the following: A.K.A. The Dynamic Duo or The Caped Crusaders 
and format it as follows: Heading 3; Centered; type color= Aqua.
When you cut and paste text from another source it can sometimes come in with formatting from that source. Make sure you apply formatting to it once it is in FrontPage to guarantee that it will display correctly.

Open Public>Mazza>Batman Practice Site>TV Batman Website Text.doc and copy the index.htm body text and Paste it into the index.htm page below A.K.A. The Dynamic Duo or The Caped Crusaders. Format the text as Normal (set the type to white if it isn’t already).
In FrontPage you create and work with Tables much in the same way as you do in MS-Word.


Put your cursor below the 3 paragraphs of body text that you just formatted and go to Table>Insert>Table. A dialog box will appear. Set the Rows to 5 and the Columns to 2. 
Leave all the other settings as they are and click OK. An empty table grid will appear.


Enter the following information into the table on index.htm.
	Date Aired
	1/22/66 to 3/14/68

	Time Aired
	Wednesday and Thursday @ 7:30 pm

	Network Aired
	ABC

	Number of Episodes
	120

	Studio
	Fox Television Studios



Below the table, Insert and Center bruce_to_batman.gif (Insert>Picture>From File).

In FrontPage, Interactive Buttons are pre-designed buttons that show an effect as the viewers cursor travels 
over the button. 

In index.htm below bruce_to_batman.gif, Insert 3 Interactive Buttons 
(Insert>Interactive Buttons) using the following information:

	Button
	Text
	Link
	 (Click on the 
Image Tab)

	Embossed Capsule 1 (blue)
	The HEROES
	leave empty for now
	Make the Button a 
GIF Image

	Embossed Capsule 2 (green)
	The VILLAINS
	leave empty for now
	Make the Button a 
GIF Image

	Embossed Capsule 4 (yellow)
	The GADGETS
	leave empty for now
	Make the Button a 
GIF Image



The Interactive Buttons should all be on the same horizontal line and you can put 5 spaces between them to spread them out.


Right Click on The HEROES Interactive Button and select Hyperlink. On the left of the dialog box where it says Link To: select Create New Document and where it says Name of New Document: enter heroes.htm and click OK. Also link The VILLAINS button to villains.htm and The GADGETS button to gadgets.htm.


Save all three pages, go to index.htm and select File>Preview in Browser. Confirm that the links to the three subordinate pages are working. Use Back in the browser to return to the index.htm page since heroes.htm, villains.htm and gadgets.htm do not have navigation buttons yet.

Return to FrontPage and open heroes.htm. Go to File>Properties and enter TV Batman Heroes Web Page in the Title field. Click on the Formatting Tab and set the Background of the page to a Dark Blue (Background>More Colors>Custom>Red=0, Green=0, Blue=85), Set Text to White, Hyperlink to Yellow, Visited Hyperlink to Silver, Active Hyperlink to Red. Click on the Advanced Tab and set the Top, Bottom, Right and Left Margins to 12 Pixels. Select OK to exit the Page Properties Dialog Box and Save (File>Save).

At the top of heroes.htm, Insert and Center batman_logo.gif.

Under batman_logo.gif Insert and Center heroes.gif. 
Tables can be used to help you with layout and alignment on a webpage.

Under heroes.gif Insert and Center a table with the following settings (Rows: 6, Columns: 2, 
Cell Padding: 18, Borders Size: 0).


Click on the left side border of the top row of the table to select it. Merge the two cells by selecting Table>Merge Cells.

Simple text blocks like the one below were used for navigation bars in early web sites. By selecting Shift-\ you can generate the “|” character . 


From TV Batman Website Text.doc copy the heroes.htm navigation text 

| BATMAN | ROBIN | BATGIRL | ALFRED | COMMISSIONER |
| HOME |
and paste it into the merged cells. Format the text in White, Heading 3.


Select the word HOME and then Right Click and select Hyperlink. Under Link To: select Existing File or Web Page and then select the index.htm from the file list.

In the table do the following:
Insert the picture batman.jpg in the left column of row 2.
Insert the picture robin.jpg in the left column of row 3.
Insert the picture batgirl.jpg in the left column of row 4.
Insert the picture alfred.jpg in the left column of row 5.
Insert the picture commiss.jpg in the left column of row 6.

From the file TV Batman Website Text.doc copy the heroes.htm picture captions and paste them into the appropriate cells to the right of the pictures on the heroes.htm webpage. Set all the text to Normal.


In heroes.htm, select the Cells in the right Column of the table and set the Vertical Alignment 
to Top (Select the Cells>Right Click>Cell Properties>Vertical alignment>Top).

It is possible to set Hyperlinks in a webpage that navigate the viewer to other parts of the page. To do this you must first set Bookmarks which are labeled markers to locations within the page.

Place the cursor before the text of each heroes’ name within the table and Insert and name a Bookmark for each hero (Insert>Bookmark). A flag will appear where the Bookmark was set.

In other web design programs such as Adobe Go-Live, Bookmarks are called Anchors.


Create a Hyperlink from the text of each Heroes’ names in the navigation bar to the Bookmark. Select the text for the hero’s name and Right-Click and select Hyperlink.* On the left of the dialog box where it says Link To: select Place in This Document and then click on the appropriate Bookmark. 

*If spell check options appear when you right click, then select Ignore All and then you can right click again and get to the Hyperlink selection.

At the top of heroes.htm put your cursor before batman_logo.gif and add a Bookmark called top. At the bottom of heroes.htm below the Commissioner picture type RETURN TO TOP. Select RETURN TO TOP and click on the Center Align icon. Next Right-Click on the selected RETURN TO TOP and choose Hyperlink from the pop-up list. On the left of the dialog box where it says Link To: select Place in This Document and then click on the top Bookmark. 

Create the Villains and  Gadgets web pages using the same steps, settings and commands as you used to create the heroes web page.


Set the webpage properties (Title, Background/Hyperlink Colors, Margins)

Insert the Batman logo


Insert the page header


Insert the layout table (6 rows by 2 columns)

Merge the cells in the top row


Insert the navigation text


Create the Hyperlink to the Home Page


Insert the pictures (use the flowchart on page one for 
the order)

Insert the picture captions

Insert and name the Bookmarks


Create the Hyperlinks to Bookmarks

Add the RETURN TO TOP functionality
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The Joker


The Riddler


The Penguin


Mr. Freeze


Catwoman





Gadgets


Batcave


Batmobile


Batboat


Batcycle


Batsignal
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